[VSCode] No commands showing

As of this morning, the Cody Commands panel just shows “There is no data provider registered that can provide view data.”

The Settings & Support panel looks fine, but clicking on anything just gives an error message: “command ‘cody.*’ not found” (where * is “sidebar.keyboardShortcuts”, or “show-page”, etc.)

Selecting “Cody: Trigger Autocomplete at Cursor” gives the error: “command ‘cody.autocomplete.manual-trigger’ not found”

I have tried uninstalling the extension, deleting ~/.vscode/extensions/sourcegraph.cody-ai* and ~/.config/cody-ai, and reinstalling it, but the behavior does not change.

After reinstallation, I am not asked to authenticate myself, but my chat from yesterday still shows, which suggests there’s a setting I still need to clear.

Cody Extension v1.22.3
VSCode 1.90.2
MacOS 14.5

1 Like

Surprisingly, when I click a red underline, do a cmd+., and Ask Cody to Fix, Cody does engage.

I am not sure if this will help you but it solved an issue for me where it could not use the embeddings it created, so another possible location you can try deleting: go into C:\Users\Sinis\AppData\Roaming\Code\User\globalStorage and delete the sorcegraph.cody-ai

Did you get this sorted? Experiencing the same issue here.

Alas, no. I’ve switched to another LLM-driven code assistant.

Well that’s discouraging, that, and the fact you haven’t yet received a response in five days. What did you switch to, if I may ask?

Double. They gave me a 1-month free trial. Tbh, I don’t think I like it as much!

Thanks! If worse comes to worst, I’ll check them out.

Yeah it is a little disheartening to see posts go unanswered for multiple days and there really is no excuse for that. I do hope they get better about participating here. If you got a problem it seems the quickest or most reliable way to get help is opening a support ticket. I have to say tho that out of all the coding assistants Cody seems to be the best, when it works properly :grin: hopefully it will continue to improve. I love seeing the frequent fixes and updates that they have been doing.

Automagically Cody fired up this morning. I did submit a ticket. Not sure if there is something they do routinely, back-end, when they get a ticket of this type that fixed it? I had the chance to test a couple of other assistants during the downtime, Tabnine and Double. I agree with you, Cody is just better. @free.creepy.hugs: If you haven’t found a suitable replacement it might be worth giving it another shot now.

Which version of VS Code do you use?

The transition from version 1.89 to 1.90 means that the stable release of Cody may have been compiled with 1.89, while the pre-release is compatible with VS Code 1.90. If you’re currently using 1.90, it’s advisable to opt for the pre-release version of Cody. The issue arises due to the lack of backward compatibility in recognizing contribution points on the VS Code side.

Yeah, I’m on VS Code 1.90.2. I switched to pre-release Cody and… no dice. Now to try an earlier version of VS Code, I guess?