Custom commands don't save on mac

When I try to create a new custom command and then at the end it asks me to choose the save location it will let me choose but then it doesn’t safe. No matter if I store it globally or locally in the workspace.

Hey @35e could you provide your IDE/OS/Cody versions.

Also can you please paste your ~/.vscode/cody.json file?

You can do it in VS Code.

If you want to record your screen that will work too. =)

Hi i’m on Sonoma 14.4.1
Visual Studio Code
Version: 1.89.1 (Universal)
Cody v1.16.7

I didn’t have a cody.json even after trying to create a custom command. Then I created the file manually hoping it would write in it. But the file keeps being empty even after trying to add a new custom command.

Thanks. Can you please open a terminal and run

ls -alh cody.json

You should see something like this:
-rw-r--r-- 1 username staff 5.4K May 1 07:31 cody.json

Paste that here.

When I type it inside the .vscode folder where I made that file myself I get the following output:

-rw-r–r-- 1 35e staff 0B May 11 00:49 cody.json

Weird. Before submitting a bug report can you try one last thing?

Close VS Code > Open System Settings > Type Security > Choose Full Disk Access add Visual Studio Code > Open VS Code > Try creating a custom command.

Report back if it works or not.

Just tried it, still not working unfortunately .

Ok well undo that last change.

Try

█ logEvent: CodyVSCodeExtension:command:custom:build:executed  {
  "details": "VSCode"
}
█ telemetry-v2: recordEvent: cody.command.custom.build/executed  {
  "parameters": {
    "version": 0,
    "metadata": [
      {
        "key": "contextSelection",
        "value": 10
      },
      {
        "key": "guardrails",
        "value": 0
      },
      {
        "key": "ollama",
        "value": 0
      },
      {
        "key": "tier",
        "value": 1
      }
    ]
  },
  "timestamp": "2024-05-11T19:37:47.709Z"
}

I see the following in the output when creating a new command